Configuration Frame Relay avec ipv6

Posted by IT2 0 commentaires

Frame-Relay Point-to-Point

Déférente sous-réseau
Seulement mappage dynamique
Sous-interface



R1
Router(config)#interface Srial0/0/0
Router(config-if)#encapsulation frame-relay
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#interface Serial0/0/0.102 point-to-point
Router(config-subif)#ipv6 address 2001::1/64
Router(config-subif)#frame-relay interface-dlci 102
Router(config)#interface Serial0/0/0.103 point-to-point
Router(config-subif)#ipv6 address 2002::1/64
Router(config-subif)#frame-relay interface-dlci 103
Routage RIP ng
Router(config)#ipv6 unicast-routing
Router(config)#ipv6 router rip cisco
Router(config-rtr)#exit
Router(config-if)#interface Serial0/0/0.102
Router(config-subif)#ipv6 rip cisco enable
Router(config-subif)#interface Serial0/0/0.103
Router(config-subif)#ipv6 rip cisco enable
Router(config)#interface GigabitEthernet0/0
Router(config-if)#ipv6 rip cisco enable
R2
Router(config)#interface Serial0/0/0
Router(config-if)#no sh
Router(config-if)#encapsulation frame-relay
Router(config)#interface Serial0/0/0.201 point-to-point
Router(config-subif)#ipv6 address 2001::2/64
Router(config-if)#frame-relay interface-dlci 201
Routage RIP ng
Router(config)#ipv6 unicast-routing
Router(config)#ipv6 router rip cisco
Router(config-rtr)#exit
Router(config-if)#interface Serial0/0/0.201
Router(config-subif)#ipv6 rip cisco enable
Router(config)#interface GigabitEthernet0/0
Router(config-if)#ipv6 rip cisco enable
R3
Router(config)#interface Serial0/0/0
Router(config-if)#no sh
Router(config-if)#encapsulation frame-relay
Router(config)#interface Serial0/0/0.301 point-to-point
Router(config-subif)#ipv6 address 2002::2/64
Router(config-if)#frame-relay interface-dlci 301
Routage RIP ng
Router(config)#ipv6 unicast-routing
Router(config)#ipv6 router rip cisco
Router(config-rtr)#exit
Router(config-if)#interface Serial0/0/0.301
Router(config-subif)#ipv6 rip cisco enable
Router(config)#interface GigabitEthernet0/0
Router(config-if)#ipv6 rip cisco enable

Frame-Relay Point-to-Multipoint



R1
Router(config)#interface Serial0/0/0
Router(config-if)#ipv6 address 2001::1/64
Router(config-if)#ipv6 address FE80::1 link-local
Router(config-if)#no shu
Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay map ipv6 2001::2 102
Router(config-if)#frame-relay map ipv6 2001::3 103
Router(config-if)#frame-relay map ipv6 FE80::2 102 broadcast
Router(config-if)#frame-relay map ipv6 FE80::3 103 broadcast
routage
Router(config)#ipv6 router ospf 1
Router(config-rtr)#router-id 4.4.4.4
Router(config)#interface GigabitEthernet0/0
Router(config-if)#ipv6 ospf 1 area 1
Router(config-if)#interface Serial0/0/0
Router(config-if)#ipv6 ospf 1 area 1
Router(config-if)#ipv6 ospf network broadcast
Router(config-if)#ipv6 ospf neighbor FE80::2
Router(config-if)#ipv6 ospf neighbor FE80::3
R2
Router(config)#interface Serial0/0/0
Router(config-if)#ipv6 address 2001::2/64
Router(config-if)#ipv6 address FE80::2 link-local
Router(config-if)#no sh
Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay map ipv6 2001::1 201
Router(config-if)#frame-relay map ipv6 FE80::1 201 broadcast
routage
Router(config)#ipv6 router ospf 1
Router(config-rtr)#router-id 3.3.3.3
Router(config)#interface GigabitEthernet0/0
Router(config-if)#ipv6 ospf 1 area 1
Router(config-if)#interface Serial0/0/0
Router(config-if)#ipv6 ospf 1 area 1
Router(config-if)#ipv6 ospf network broadcast
Router(config-if)#ipv6 ospf neighbor FE80::1
R3
Router(config)#interface Serial0/0/0
Router(config-if)#ipv6 address 2001::3/64
Router(config-if)#ipv6 address FE80::3 link-local
Router(config-if)#no sh
Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay map ipv6 2001::1 301
Router(config-if)#frame-relay map ipv6 FE80::1 301 broadcast
routage
Router(config)#ipv6 router ospf 1
Router(config-rtr)#router-id 2.2.2.2
Router(config)#interface GigabitEthernet0/0
Router(config-if)#ipv6 ospf 1 area 1
Router(config-if)#interface Serial0/0/0
Router(config-if)#ipv6 ospf 1 area 1
Router(config-if)#ipv6 ospf network broadcast
Router(config-if)#ipv6 ospf neighbor FE80::1


Comment Activez Windows 10 gratuitement

Posted by IT NISRO 0 commentaires
Windows 10 est un système d'exploitation de la famille Windows NT développé par la société américaine Microsoft. Officiellement présenté le 30 septembre 2014, il est disponible publiquement depuis le 29 juillet 2015. Wikipédia

 Activez Windows 10 gratuitement

Pour activez Windows 10 gratuitement suivez les étapes suivants :

1. ouvrir le bloc-notes 
2. Collez ceci:

@echo off
title Windows 10 ALL version activator&cls&echo ************************************ &echo Supported products:&echo - Windows 10 Home&echo - Windows 10 Professional&echo - Windows 10 Enterprise, Enterprise LTSB&echo - Windows 10 Education&echo.&echo.&echo ************************************ &echo Windows 10 activation...
cscript //nologo c:\windows\system32\slmgr.vbs /ipk TX9XD-98N7V-6WMQ6-BX7FG-H8Q99 >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk 3KHY7-WNT83-DGQKR-F7HPR-844BM >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk 7HNRX-D7KGG-3K4RQ-4WPJ4-YTDFH >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk PVMJN-6DFY6-9CCP6-7BKTT-D3WVR >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk W269N-WFGWX-YVC9B-4J6C9-T83GX >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk MH37W-N47XK-V7XM9-C7227-GCQG9 >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk NW6C2-QMPVW-D7KKK-3GKT6-VCFB2 >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk NW6C2-QMPVW-D7KKK-3GKT6-VCFB2 >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk 2WH4N-8QGBV-H22JP-CT43Q-MDWWJ >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk NPPR9-FWDCX-D2C8J-H872K-2YT43 >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk DPH2V-TTNVB-4X9Q3-TJR4H-KHJW4 >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk WNMTR-4C88C-JK8YV-HQ7T2-76DF9 >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ipk 2F77B-TNFGY-69QQF-B8YKP-D69TJ >nul
echo ************************************ &echo.&echo.&set i=1
:server
if %i%==1 set KMS_Sev=kms.chinancce.com
if %i%==2 set KMS_Sev=NextLevel.uk.to
if %i%==3 set KMS_Sev=GuangPeng.uk.to
if %i%==4 set KMS_Sev=AlwaysSmile.uk.to
if %i%==5 set KMS_Sev=kms.chinancce.com
if %i%==6 set KMS_Sev=kms.shuax.com
if %i%==7 exit
cscript //nologo c:\windows\system32\slmgr.vbs /skms %KMS_Sev% >nul
cscript //nologo c:\windows\system32\slmgr.vbs /ato | find /i "successfully" && (echo.& ************************************ & echo. & choice /n /c YN /m "Do you want to restart your PC now [Y,N]?" & if errorlevel 2 exit) || (echo The connection to the server failed! Trying to connect to another one... & echo Please wait... & echo. & echo. & set /a i+=1 & goto server)
shutdown.exe /r /t 00

3. Enregistrez en tant que .bat et exécutez

:)





Comment Configurer un service d'annuaire LDAP

Posted by IT2 0 commentaires

LDAP (Light Directory Access Protocol) est un service d'annuaire dérivé de la norme X.500. La norme X.500 est très lourde, LDAP en est une version allégée ("light").

Un serveur LDAP permet de centraliser des informations très diverses. Il offre de nombreux avantages :
• un serveur d'annuaire (recensement de tous les objets d'un système) : c'est la fonction la plus connue.
• Information sur les utilisateurs (nom, prénom...), et données d'authentification pour les utilisateurs :
cela permet aussi la définition de droits.
• Information pour les applications clientes et fonctions de serveur d'accès itinérant : cela permet de
stocker ses informations personnelles sur un serveur et de les récupérer lors de la connexion;
• bien d'autres choses...

Le modèle de données

LDAP fournit un modèle d'organisation des données. Ces données sont organisées sous forme hiérarchique. L'arbre est nommé Directory Information Tree (DIT). Le sommet (racine), contient le "suffixe". Chaque noeud représente une "entrée" ou "Directory Entry Service" (DSE). Les données sont stockées sur un format de base de données hiérarchique de type "dbm".

Une entrée (DSE) dans le DIT correspond à un objet abstrait (organisation, ressource) ou concret (personne, équipement...). Les objets possèdent une description dans une "classe d'objet". Une classe d'objet donne une représentation modélisée des objets qu'elle représente en caractérisant tous les attributs des objets.

Comment Configurer un service d'annuaire LDAP
Comment Configurer un service d'annuaire LDAP



Entrées

Chaque entrée correspond à une seule unité (objet) dans un répertoire LDAP. Chaque entré est identifié de manière unique par sont nom distinctif ou DN (Distinguished Name).

Attributs

Les entrées peuvent êtres considérés comme des objets possédant certains attributs. Par exemple, un employé pourrait être représenté par une entrée LDAP. Parmi les attributs associé à un employé on pourrait retrouvé le nom, le prénom, l’âge… Il est possible de définir des attributs obligatoire et optionnel.


Classes d'objet

On regroupe les objets qui sont du même domaine dans une classe d'objet, celle-ci est caractérisée
par des attributs obligatoires ou optionnels et un type. Les types de classe d'objet sont:

• type structurel : classes d'objets concrets de l'annuaire (personnes, groupes de personnes, ...).• type auxiliaire : classes d'objets permettant d’ajouter des informations (attributs)supplémentaires à des classes d'objet de type structurel déjà existantes.• type abstraire : classes d'objet qui existent par défaut et qui n'ont pas de signification concrète,par exemple la classe top est la classe d'objet générique, toutes les autres 0classes dérivent de cetteclasse.


Schémas

Un schéma décrit toutes les règles qu'utilisent le serveur LDAP pour décrire les classes d'objets (attributs, syntaxe, ...).

Fichiers de configuration

Les fichiers de configuration sont installés dans le répertoire /etc/openldap/. Cidessous figure la liste des fichiers et répertoire important :

• /etc/openldap/ldap.conf : Fichier de configuration pour les applications clientes qui utilise les bibliothèques.• /etc/openldap/slapd.conf : Fichier de configuration du démon slapd.• /etc/openldap/schema/ : Répertoire contenant le schéma utilisé par le démon slapd.


Mise en place du schéma d’annuaire

Le répertoire /etc/openldap/schema/ contient la définition du schéma utilisé par LDAP. Les définitions du système d’attribut et de définition de classe d’objet sont placées dans des fichiers différents. Ces derniers sont référencés dans le fichier /etc/openldap/sldap.conf à l’aide de l’instruction include. Voici un extrait de ce fichier :

# $OpenLDAP: pkg/ldap/servers/slapd/slapd.conf,v 1.8.8.4 2019/08/26 17:06:18
# See slapd.conf(5) for details on configuration options.
# This file should NOT be world readable.
include /usr/share/openldap/schema/core.schema
include /usr/share/openldap/schema/cosine.schema
include /usr/share/openldap/schema/corba.schema

Mise en place du schéma d’annuaire

Une classe d'objet est définie par un nom, un OID (Object IDentifier), la liste des attributs (facultatifs et obligatoires), un type. Le type est lié à la nature des attributs utilisés.


objectclass ( 2.5.6.6 #OID
NAME 'person'
DESC 'RFC2256: a person'
SUP top
STRUCTURAL
MUST
( sn $ cn )
MAY
( userPassword $ telephoneNumber $ seeAlso $ description ) )


Configuration du serveur OpenLDAP

#######################################################################
# ldbm database definitions
#######################################################################
# Choix du format de base de données pour le stockage des informations.
database ldbm
# Configurer le suffixe (racine) de l'annuaire en fonction du domaine DNS
suffix "dc=my-domain,dc=org"
# L'administrateur de l'annuaire
rootdn "cn=Manager,dc=my-domain,dc=org"
# Le mot de passe de l'administrateur, préférer une option cryptée
# rootpw secret
# rootpw {crypt}ijFYNcSNctBYg
# Emplacement de la base de données
directory /var/lib/ldap
# Accés par défaut sur la base
defaultaccess read
access to <what> [ by <who> <none | compare | search | read | write>]
# Donne un accés en écriture pour le manager du domaine
access to * by dn="cn=Manager,dc=mydomain,dc=org" write
# Donne un accés en lecture à tout le monde sur la base
access to * by * read
# Donne un accés en écriture sur un attribut pour le manager en lecture pour les autres.
access to attr=uid
by dn="manager,dc=mydomain,dc=org" write
by * none


Le format d'échange de donnée LDIF

Le format d'échange permet l'import/export de données des bases, mais sert également pour l'ajout ou la modification. Les données sont en ASCII codées en UTF-8, sauf pour le binaire qui est codé en base64 (images par exemple).


Syntaxe générale :
dn: <distinguished name
objectClass: <object class
objectClass: <object class
...
<attribute type:<attribute value
<attribute type:<attribute value
...
Exemple :
dn: cn= Manon Des Sources, ou= compta, dc=mydomain, dc=org
objectClass: person
objectClass: organization
cn: user1 USER1
sn: USER1
givenName: AM
userPassword: {sha}KDIE3AL9DK
uid: amg





Comment installer CentOS 8

Posted by IT2 0 commentaires
Dans ce tutoriel on va vous montrez  comment installer une machine virtuel Linux CentOS 8.

Comment installer CentOS 8

Pour faire sa, il faut avoir Virtualbox déjà installer sur votre poste et avoir une image ISO de CentOS 8.




VirtualBox , téléchargement et  l'installation voir ici.
Image ISO CentOS 8 téléchargeable ici.





Comment migrer gratuitement de Windows 7 vers Windows 10 sans réinstallation

Posted by IT NISRO 0 commentaires

Depuis 14  janvier 2020 Microsoft a mis fin de sont système d'exploitation Windows 7.
si votre système continue à fonctionner sans problème, il ne sera plus corrigé en cas de faille de sécurité ou de bug . Il est donc temps d’opter pour une migration un version plus récent de système d'exploitation. 
et la bonne chose que cette migration c'est gratuite quand il s’agit d'une migration a Windows 10.

Comment migrer gratuitement de Windows 7 vers Windows 10 sans réinstallation


Pour optez a cette migration il suffit de télécharger l’outil de mise à niveau de Microsoft, puis le lancez pour exécuter la mise a jour de Windows 7 a Windows 10. 


Voici comment mettre à niveau de Windows 7 vers Windows 10:

  1. Sauvegardez tous vos documents, applications et données importants
  2. Rendez-vous sur le site de Microsoft téléchargement de Windows puis l'outil de mise a niveau.
  3. Dans la section Créer un support d'installation de Windows 10, sélectionnez «Télécharger l'outil maintenant» et exécutez l'application
  4. Lorsque vous y êtes invité, choisissez «Mettre à niveau ce PC maintenant».
Comment migrer gratuitement de Windows 7 vers Windows 10 sans réinstallation







CCNA 200-301 Certification Guide officiel

Posted by IT2 0 commentaires

Le livre organise les chapitres en parties dans le but de vous aider à étudier pour l'examen. Chaque partie regroupe un petit nombre de chapitres connexes. 

Ensuite, le processus d'étude vous suggère de faire une pause après chaque partie pour faire un examen de tous les chapitres de la partie. 

CCNA 200-301 Guide officiel des certificats


La figure répertorie les titres des huit parties et les chapitres de ces parties (par numéro de chapitre) pour ce livre.




CCNA 200-301 Certification Guide officiel
CCNA 200-301 Certification Guide officiel

Téléchargement




Réseaux sans Fil 802.11.

Posted by IT NISRO 0 commentaires


Ce livre traite des réseaux locaux sans fil (WLAN) basés sur les normes IEEE802.11. Il a trois objectifs principaux:


• Présenter les principes des réseaux sans fil 802.11 et montrer comment configurer l'équipement afin de mettre en œuvre diverses solutions réseau.


• Fournir une compréhension des implications de sécurité des réseaux sans fil et montrer comment les vulnérabilités peuvent être atténuées.


• Présenter les protocoles 802.11 sous-jacents et construire des modèles mathématiques afin d'analyser les performances dans un environnement WLAN.



Réseaux sans Fil 802.11.
Réseaux sans Fil 802.11.


Téléchargement




Comment réparer l'erreur Grub: No Such Partition Grub Rescue

Posted by IT NISRO 0 commentaires

Dans ce tutoriel on  va voir comment réparer l'erreur Grub: No Such Partition Grub Rescue.

Comment réparer l'erreur Grub: No Such Partition Grub Rescue
Comment réparer l'erreur Grub: No Such Partition Grub Rescue

1 : ls pour listes tous les disque dur .
2: Puis ls pour chaque disque dur jusqu’à ce que vous trouvez disque système.
3: Apres set boot=(hdx,y) Par exemple : set boot=(hd0,msdos6).
4: Puis set prefix=(hdx,y) Par exemple : set prefix=(hd0,msdos6)/boot/grub.
5: Pour démarrer normal module : insmod normal
6: normal







Technologie de communication mobile et sans fil 5G

Posted by IT2 0 commentaires

ce livre est un aperçu complet de l'état actuel du paysage 5G. Couvrant tout, des cas d'utilisation les plus probables, à un large éventail d'options technologiques et d'architectures de systèmes 5G potentielles, aux problèmes de spectre, il s'agit d'une référence essentielle pour les universitaires et les professionnels impliqués dans les communications sans fil et mobiles.


Technologie de communication mobile et sans fil 5G
Technologie de communication mobile et sans fil 5G




Comment créer une clé USB amorçable ( bootable ) avec RUFUS sous Windows pour Ubuntu 20.04

Posted by IT2 0 commentaires

Dans ce tutoriel on va voir comment préparer une clé USB amorçable ( bootable ) a l'aide de l'utilitaire Refus sous Windows pour Ubuntu 20.04.





Pour téléchargement de Rufus et Ubuntu

Rufus : https://bit.ly/2MzWOd1 Ubuntu : https://bit.ly/2MEsLRw

Comment installer VirtualBox sous Ubuntu 20.04 depuis Logithèque et avec Terminal

Posted by IT2 0 commentaires
Pour l'installation de virtualbox sous linux il'y a plusieurs façon de l'installer.

Aujourd’hui on va prendre le cas de l'installer sous Ubuntu 20.04 a l'aide de l'interface graphique Logithèque et avec terminal.

Partie 1 : l'installation depuis logithèque

Pour cette partie l'installation est très simple il suffit d'aller dans logithèque Ubuntu puis chercher Virtualbox après on lance l'installation .

Partie 2 : Terminal 

Pour Ubuntu 16.04 32 bits:

>_ echo "deb http://download.virtualbox.org/virtualbox/debian $(lsb_release -sc) contrib" | sudo tee /etc/apt/sources.list.d/virtualbox.list


Pour Ubuntu 18.04 64 bits et plus:

>_ echo "deb [arch=amd64] http://download.virtualbox.org/virtualbox/debian $(lsb_release -sc) contrib" | sudo tee /etc/apt/sources.list.d/virtualbox.list
 Apres ajoutez la clé de signature du dépôt avec la commande :

>_ wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -

Avant de lance l'installation de virtualbox il faut rafraîchir la liste des paquets disponible. Cela peut se faire dans un terminal avec la commande :

>_ sudo apt update

A la fin on lance l'installation de virtualbox :

>_ sudo apt install virtualbox


Pour le coté pratique voila tutoriel vidéos









Linux Command Line et Shell Scripting

Posted by IT2 0 commentaires

Ce livre vous guide à travers les bases de la ligne de commande Linux et dans des sujets plus complexes, tels que la création de vos propres scripts shell. Le livre est divisé en quatre parties.


Linux Command Line and Shell Scripting Bible by Richard Blum, Christine Bresnahan




Membres